Windows XP Users to Miss Out on Windows Live Essentials 2010 / Wave 4

"Windows Live Essentials 2010 / Wave 4 from Microsoft is just around the corner and according to reports, the new release will only be available for Windows Vista SP2 and Windows 7 users."

Search News

Windows Live Essentials 2010 / Wave 4 from Microsoft is just around the corner and according to reports, the new release will only be available for Windows Vista SP2 and Windows 7 users. Windows XP users will no longer will able to upgrade their Windows Live Messenger or any of the other tools offered as part of Windows Live Essentials 2010 / Wave 4.

Microsoft released the Platform Preview of its browser – Internet Explorer 9 with support for Windows Vista SP 2 and Windows 7 operating systems only, and stated that Windows XP users will have to make do with the older versions only. The move is basically a ploy to encourage users of the older OS to upgrade or buy new ones. Now the OS-maker has extended this to the latest releases of its Windows Live Essentials / Wave 4 as well.

Microsoft has confirmed that Windows Live Essentials 2010 / Wave 4 Beta works only with its more recent operating systems. Users who have been invited for the beta testing of Messenger, Mail, Writer, Photo Gallery, Movie Maker, and Family Safety have reportedly not been able to test the applications on systems running Windows XP.

Quoting LiveSide, tech portal LiveSino has reported the following description of Windows Live Essentials Wave 4: “Windows Live Essentials 2010 Beta includes free programs from Microsoft for photos, movies, instant messaging, email, blogging, and more. Get them all in one download and get more done with Windows. Essentials is currently available in seven languages and requires Windows 7 and Windows Vista.”

This description though, is yet to be officially confirmed by Microsoft and so there might be a glimmer of hope for Windows XP users. The only officially available details are about the platforms Windows Live Essentials Wave 4 will support and these include Windows Vista SP 3 x86 and x64 (with Platform Update for Windows Vista), Windows 7, Windows Server 2008 SP2 (with Platform Update for Windows Server 2008), and Windows Server 2008 R2. So once again, no word on Windows XP support!

Discuss in our forums

«Prev 1 Next»

Most Recent Comments

Reply
x

Register for the OC3D Newsletter

Subscribing to the OC3D newsletter will keep you up-to-date on the latest technology reviews, competitions and goings-on at Overclock3D. We won't share your email address with ANYONE, and we will only email you with updates on site news, reviews, and competitions and you can unsubscribe easily at any time.

Simply enter your name and email address into the box below and be sure to click on the links in the confirmation emails that will arrive in your e-mail shortly after to complete the registration.

If you run into any problems, just drop us a message on the forums.