Hiper launches first model of new PSU series: S625 80PLUS Bronze certified

"Hiper introduces its brand new S Series with the first model: S625"

Search News

  • Scrolling Image
  • Scrolling Image
Hiper launches first model of new PSU series: S625 80PLUS Bronze certified OC3D Official Press Release logo

Hiper introduces its brand new S Series with the first model: S625. This 625 Watts power supply has been certified 80 PLUS® Bronze by www.80plus.org. The Hiper S625 performs extremely well and exceeds the 80PLUS requirements by far.

The new S Series will offer a range of highly reliable and stable performing PSUs with the well-known excellent built quality by Hiper. It comes in Gun Metal with a new logo and packaging design. The Hiper S625 will be available soon and represents best price/performance ratio at probably the lowest RRP of all A-brand 625W PSUs with 80 PLUS® Bronze certification: US$ 95 / € 72 / £ 65 (excl. VAT). The new model has also been approved for NVIDIA SLi and comes with a 3 years RTB warranty.

Hiper S625_1 Hiper S625_2

80 PLUS® Bronze Certified – average efficiency >85%

· Designed for NVIDIA SLI™

· Represents best price/performance ratio

· New PCI-E 8 pin available. (8 pin to 6 pin adaptors included)

· Four independent 12V rails.

· Mesh body Patented construction eliminates all hot spots and extends the life of the unit.

· Complies with latest ATX12V v2.2 form factor.

· Fully compatible with AMD 64 bit and Intel LGA processors.

· Active PFC.

· Gold plated connectors for minimum power loss and optimal conductivity.

· PCI-E (6-pin), PCI-E (8-pin), SATA, Molex with EZ-Grip, floppy, P8 & P4 connectors.

· Modular-Power-Cord (European model only). Patented

· 20 dB(A) under normal load.

· 3 year RTB warranty

Recommended retail prices:

Hiper S625 US$ 95 / € 72 / £ 65 (excl. VAT).

Hiper S Series PSU product page

Discuss the new Hiper S Series PSU's in our forum
«Prev 1 Next»

Most Recent Comments

05-01-2009, 09:11:32

°TheMadDutchDude°
Hey guys, after playing on the CS: S server today and yesterday I noticed that the hitreg is completely out. I shot this guy 6x with an AWG (most powerful sniper and kills in one as you know) and he still didn't drop dead. I asked my friend who is pro at the game and he agrees, the hitreg is defo' out.

Please could you sort this out, it's starting to tick me off that they won't die and they come up behind me and kill me in one shot, it makes no sense!

Thanks guys.

05-01-2009, 10:32:05

Technex
What server, the aim texture one? Personally I think that this server is the best for hit reg/latency than any other I've played on. And I've been playing for 4-5 years. (most likely because it's a high quality server and very close).

Unless this has changed in the last week or two as I haven't been on it since then.

What settings do you have? rate, cl_smooth, cl_cmdrate, cl_updaterate etc?

05-01-2009, 10:34:06

°TheMadDutchDude°
I haven't actually set up CS: S for that server I don't think. Could you let me know what rates I need and I'll try again? Thanks a lot :)

A bit of a noob question (how do you set them again?) I know that you need the developers console etc etc but what do you actually type?

Thanks guys!

05-01-2009, 10:49:55

rrjwilson
Also AWP is most sniper in the game not AWG. If you mean AUG it is a auto scope rifle and not very power with bad recoil.

I've been playing CS, CS Pro, CSS for many years and find nothing out of the ordinary on the OC3D server apart from a slight choke now and then.

05-01-2009, 11:25:14

°TheMadDutchDude°
Ahh okay. LOL Sorry I thought it didn't sound right when I posted it. I meant AWP.

Very strange though how I hit the guy 6 times and he didn't die? and then killed him with one pistol shot? Mhmm.

Anyways, I'm going back on it now, if I get the same problems again I will let you guys know.

05-01-2009, 11:42:20

Luigi
lol dude, the hit reg on there is a lot better than most.. the only way you can get half descent reg is to go on small servers (10 man) or Lan It :)

05-01-2009, 13:29:52

°TheMadDutchDude°
Yeah I know now :p

I do apologise for making the server out to what it was. It was infact my net being clogged up by something (don't know what) and it wasn't at normal speeds. I was getting 55KB/s downloads which is pretty poor to say the least.. Back to dial-up anyone? :D

My ping was 300+ as soon as I logged on to the server, that could be half the problem :p

Anyways, please delete this thread. No need for it.

05-01-2009, 13:35:03

Ham
Ill just close it ;)
Reply
x

Register for the OC3D Newsletter

Subscribing to the OC3D newsletter will keep you up-to-date on the latest technology reviews, competitions and goings-on at Overclock3D. We won't share your email address with ANYONE, and we will only email you with updates on site news, reviews, and competitions and you can unsubscribe easily at any time.

Simply enter your name and email address into the box below and be sure to click on the links in the confirmation emails that will arrive in your e-mail shortly after to complete the registration.

If you run into any problems, just drop us a message on the forums.