4870 X2 listed early

"etailers jumping the gun"

Search News

HD4870 X2 listed early
 
For those of you eagerly awaiting the arrival of the Radeon HD4870 X2, the wait is almost over. While the card was rumoured to arrive on the 28th July it now appears more likely that mid to late August will see retailers having them on their shelves. However some retailers are jumping the gun and listing the card already:
 
We found Sapphire's HD4870 X2 2GB GDDR5 listed for €433 on two sites. No surprise price-wise, and as expected the GDDR5 flavored version comes first. The card runs at 2x 750MHz and 2x 900MHz for the core and memory. It has a 2x 256-bit memory interface, 2x 800 stream processors and 2x 40 texture units...Nvidia's 55nm GT200 is expected in September.
 
Link to website listing
 
The DDR3 version of the HD4870 X2 is expected to arrive a little later and around the same price as the NVIDIA GTX280.
 
Would you pay €433 for the Radeon HD4870 X2?
 
Discuss in our forum
«Prev 1 Next»

Most Recent Comments

01-08-2008, 11:20:52

PV5150
Jim can I get you to check something for me please when you get a chance?

I replied to the news team thread and mine is the last post in there, but yet it doesn't show me as making the last post. I have cleared cache, restarted ff, restarted my comp but yet it still displays Bungral as having made the last post. Yet in the thread itself you can see it there. Let me illustrate:

Forum view

[IMG]http://upload.overclock3d.net/dwn/011623103436/freaky.jpg[/IMG]

Thread view

[IMG]http://upload.overclock3d.net/dwn/011623103436/wtf.jpg[/IMG]

Bungral's post was made in the AM and I made mine in the PM :confused::confused: Is there some database corruption as I had the same thing happen yesterday in another thread?

10-08-2008, 10:43:03

Dav0s
isnt this because of the new forum software?

it doesnt show the last post if you made it because you have read the thread. try logging out and checking, and it should show yours as the last post

10-08-2008, 11:04:08

PV5150
Hi mate. We tracked the issue down to bugs in the forum permissions. For some reason I had to approve my own posts before they'd show. With the patch that Jim applied it seemed to fix things for me. Well I haven't encountered it since anyway :)
Reply
x

Register for the OC3D Newsletter

Subscribing to the OC3D newsletter will keep you up-to-date on the latest technology reviews, competitions and goings-on at Overclock3D. We won't share your email address with ANYONE, and we will only email you with updates on site news, reviews, and competitions and you can unsubscribe easily at any time.

Simply enter your name and email address into the box below and be sure to click on the links in the confirmation emails that will arrive in your e-mail shortly after to complete the registration.

If you run into any problems, just drop us a message on the forums.